About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Campus Network Service Issues: Bagwell Education Building - 3rd Floor - October 3, 2018
Incident Report for Kennesaw State University
Resolved
Campus Network Service has been restored for the 3rd floor of the Bagwell Education Building.
Posted 12 days ago. Oct 03, 2018 - 14:01 EDT
Investigating
Some users are currently reporting intermittent service issues with the network on the 3rd floor of the Bagwell Education Building.

UITS network team is currently investigating these issues; we will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 12 days ago. Oct 03, 2018 - 12:03 EDT
This incident affected: Network (Network - Kennesaw Campus).