About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

HireTouch Service Issues - September 7, 2018
Incident Report for Kennesaw State University
Resolved
Service has been restored for the HireTouch jobs website. We thank you for your patience.
Posted 17 days ago. Sep 07, 2018 - 15:46 EDT
Investigating
Some users are currently reporting intermittent issues with the HireTouch jobs website.

University Information Technology Services and the vendor are currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 17 days ago. Sep 07, 2018 - 14:02 EDT
This incident affected: HireTouch.