About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Desire2Learn (D2L) Service Issues - April 29, 2019
Incident Report for Kennesaw State University
Resolved
USG ITS has restored full functionality for Desire2Learn.
Posted 22 days ago. Apr 29, 2019 - 15:22 EDT
Investigating
University Systems of Georgia (USG) Information Technology Services is currently reporting issues with Desire2Learn (D2L). Affected users may be experiencing latency issues and file upload problems.

USG ITS is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 22 days ago. Apr 29, 2019 - 14:12 EDT
This incident affected: D2L Brightspace.