About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Network Connectivity Issues in Student Center (2nd Floor) - April 25, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that network connectivity for the second floor of the Student Center on the Kennesaw Campus has been restored.
Posted Apr 25, 2019 - 15:56 EDT
Investigating
Some users are currently reporting service issues with the network connectivity on the second floor of the Student Center on the Kennesaw campus.

UITS is currently investigating these issues. We will provide further updates as they are available.
Posted Apr 25, 2019 - 13:28 EDT
This incident affected: Communications (Network - Kennesaw).