About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Online Parking Purchasing Service Issues Under Investigation
Incident Report for Kennesaw State University
Resolved
The ability to purchase parking online through Flexport has been restored. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Aug 02, 2018 - 18:30 EDT
Investigating
Some users are currently reporting issues with the ability to purchase parking online through Flexport.

UITS is currently investigating these issues; we will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Aug 02, 2018 - 14:53 EDT
This incident affected: Business Operations (KCash Manager).