About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Campus Network Service Issues; Marietta Campus, Kennesaw and Marietta Housing - September 6, 2018
Incident Report for Kennesaw State University
Resolved
The issue affecting the Campus Network on the Marietta Campus as well as Kennesaw and Marietta Housing has been resolved. The network will continue to be be monitored for stability. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Sep 06, 2018 - 13:18 EDT
Investigating
Network connectivity is currently unavailable on the Marietta Campus and in housing for both the Kennesaw and Marietta campuses.

University Information Technology Services is currently investigating these issues with the campus internet service provider; we will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Sep 06, 2018 - 11:46 EDT
This incident affected: Communications (Network - Kennesaw, Network - Marietta).