About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

GeorgiaFIRST PeopleSoft Financial Service Issues - February 26, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that GeorgiaFIRST PeopleSoft Financial Service is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 27, 2019 - 08:36 EST
Investigating
University Systems of Georgia (USG) is currently investigating reports of issues with the GeorgiaFIRST PeopleSoft Financial Service. Affected users may receive a password expiration notification message when trying to log in.

A workaround is to click on "No" and you should be able to continue to log in successfully.
Posted Feb 26, 2019 - 09:31 EST
This incident affected: Business Operations (ePro / Peoplesoft).