About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Wilson Annex (2nd Floor) Network Service Issues - September 6, 2018
Incident Report for Kennesaw State University
Resolved
Network connectivity has been restored on the 2nd floor of the Wilson Annex. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Sep 06, 2018 - 14:13 EDT
Investigating
Network connectivity is currently unavailable on the 2nd floor of the Wilson Annex.

University Information Technology Services is currently investigating these issues; we will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Sep 06, 2018 - 12:46 EDT