About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

DUO Multifactor Authenitcation Service Issues - February 26, 2021
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Duo is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 26, 2021 - 13:40 EST
Identified
Some users are currently reporting service issues with DUO.

DUO is currently investigating these issues.
DUO is seeing successful delivery of calls for Phone Callback authentications and is still investigating issues with SMS delivery for some customers.



You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Feb 26, 2021 - 12:09 EST
This incident affected: Accounts & Identity Management (Authentication Services).