About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Microsoft Teams Service Issues - February 18, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Microsoft Teams is functioning normally at this time.
Posted about 1 month ago. Feb 18, 2019 - 16:26 EST
Identified
Microsoft Teams is currently experiencing issues that may affect your ability to access or use the service.

UITS is working with the vendor to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted about 1 month ago. Feb 18, 2019 - 10:07 EST
This incident affected: Office 365 / Campus Email.