About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Kaltura MediaSpace Service Issues - Thursday, March 26, 2020
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Kaltura MediaSpace is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Mar 26, 2020 - 16:48 EDT
Investigating
Some users are currently reporting service issues with Kaltura MediaSpace.

Mediaspace.kennesaw.edu is currently down
D2L Brightspace Kaltura integration is currently down
Moodle.kennesaw.edu integration is currently down

The vendor and UITS are currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Mar 26, 2020 - 16:43 EDT
This incident affected: Academic & Research Services (D2L Brightspace, Kaltura MediaSpace, Moodle).