About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Student Printing Service Issues - October 9, 2018
Incident Report for Kennesaw State University
Resolved
Student Printing Service has been restored. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted 6 days ago. Oct 09, 2018 - 14:12 EDT
Investigating
Some users are currently reporting service issues with Student Printing.

UITS is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 6 days ago. Oct 09, 2018 - 14:07 EDT
This incident affected: Campus Printing (Printing).