About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Network Connectivity Issues in Chastain Pointe, Bowen Building and Campus Loop Houses - February 27, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that power and network connectivity has been restored to the following locations on the Kennesaw Campus:

Chastain Pointe (CP)
Bowen Building (BO)
Campus Loop Road Houses

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 27, 2019 - 16:00 EST
Identified
Network connectivity is down due to a power outage in the following locations on the Kennesaw Campus:

Chastain Pointe (CP)
Bowen Building (BO)
Campus Loop Road Houses

UITS is currently working to resolve these issues.
Posted Feb 27, 2019 - 08:51 EST
This incident affected: Communications (Network - Kennesaw).