About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

PeopleAdmin Service Issues - January 16, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that PeopleAdmin is functioning normally at this time. KSU customers are now able to access facultyjobs.kennesaw.edu/hr.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Jan 16, 2019 - 19:17 EST
Identified
PeopleAdmin is currently experiencing issues that may affect your ability to access or use the service.

UITS is currently working with the vendor to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Jan 16, 2019 - 09:54 EST
This incident affected: Business Operations (ePro / Peoplesoft).