About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Network Connectivity Issues in Joe Mack Wilson Student Center (Building A) - February 27, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that the network connectivity issues on the second floor of the Joe Mack Wilson Student Center (Building A) on the Marietta Campus have been resolved.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 27, 2019 - 16:08 EST
Investigating
Some users are currently reporting network connectivity issues on the second floor of the Joe Mack Wilson Student Center (Building A) on the Marietta Campus.

UITS is currently investigating these issues. We will provide further updates as they are available.
Posted Feb 27, 2019 - 08:35 EST
This incident affected: Communications (Network - Marietta).