About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Campus Telephone Service Issues - August 8, 2018
Incident Report for Kennesaw State University
Resolved
Service has been restored for the Campus Telephone Service. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted 10 days ago. Aug 08, 2018 - 18:11 EDT
Investigating
Some users are currently reporting service issues with Campus Telephone System.

The vendor is currently investigating these issues; we will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 10 days ago. Aug 08, 2018 - 16:54 EDT
This incident affected: Campus Telephone System.