About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

HireTouch Service Issues - September 20, 2018
Incident Report for Kennesaw State University
Resolved
Full service has been restored. Thank you for your patience.
Posted Sep 21, 2018 - 14:37 EDT
Update
Some individuals continue to report issues accessing HireTouch through http://jobs.kennesaw.edu. However, the system can currently be accessed at https://kennesaw.hiretouch.com. The vendor is working to restore full service.
Posted Sep 20, 2018 - 15:16 EDT
Identified
HireTouch is currently experiencing issues that may affect your ability to access or use the service.

University Information Technology Services and the vendor are currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at 470-578-6999 or service@kennesaw.edu
Posted Sep 20, 2018 - 08:16 EDT