About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

GeorgiaFIRST PeopleSoft Financial Service Issues - Thursday, February 25, 2021
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that GeorgiaFIRST PeopleSoft Financial is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 25, 2021 - 15:04 EST
Investigating
University System of Georgia (USG) Information Technology Services (ITS) is currently investigating reports of issues with the GeorgiaFIRST PeopleSoft Financial Service. Affected users may be experiencing an Oracle error when trying to access PeopleSoft.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Feb 25, 2021 - 13:30 EST
This incident affected: Business Operations (ePro / Peoplesoft).