About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Turnitin Service Issues - Monday, February 10, 2020
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Turnitin is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Mar 17, 2020 - 16:31 EDT
Investigating
Some users are currently reporting that they receive the following message when logging in to Turnitin: "Your account is about to expire." The University System of Georgia (USG) is aware of the issue and is working to resolve it.

We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Feb 10, 2020 - 08:42 EST
This incident affected: Academic & Research Services (Turnitin).