About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Increase in Targeted Phishing Attempts – January 25, 2019
Incident Report for Kennesaw State University
Resolved
You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 22, 2019 - 10:00 EST
Investigating
The University is currently experiencing an increase in phishing attempts targeting campus community members. The newest messages are requesting the purchase of Apple Store Gift Cards as birthday gifts.

If you suspect that you have clicked a malicious email link, please change your password at netid.kennesaw.edu. You can also contact the KSU Service Desk for assistance.

If you receive a suspicious email, please forward the message to abuse@kennesaw.edu. We also encourage you to regularly visit the Phish Market, a new service from University Information Technology Services cataloging known phishing attempts and other malicious emails targeting KSU community members; you can access the Phish Market at http://phishmarket.kennesaw.edu/.

What is Phishing?

Phishing is the fraudulent practice of sending emails purporting to be from reputable companies in order to induce individuals to reveal personal information, such as passwords and credit card numbers. The Phish Market catalogs these attempts as well as other malicious or exploitative emails.

Tips for Identifying Phishing Attempts

The Phish Market also includes regularly updated tips and strategies for identifying malicious messages. You can learn more here.

Contact the KSU Service Desk

We encourage you to contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999 for questions or assistance with identifying malicious emails or securing your KSU account information.
Posted Jan 25, 2019 - 17:12 EST
This incident affected: Communications (Office 365 / Campus Email).