About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Owl Express Service Issues Under Investigation - August 13
Incident Report for Kennesaw State University
Resolved
Owl Express performance has been fully restored. Thank you for your patience.
Posted Aug 13, 2018 - 11:35 EDT
Update
We are continuing to investigate this issue.
Posted Aug 13, 2018 - 08:32 EDT
Update
We are continuing to investigate this issue.
Posted Aug 13, 2018 - 08:32 EDT
Investigating
Some users are currently reporting service issues with Owl Express.

University Information Technology Services is currently investigating these issues; we will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Aug 13, 2018 - 08:21 EDT
This incident affected: Student Records (Banner / Owl Express).