About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Credit/Debit Transactions Are Unable to be Processed at the K-Cash Machines - January 7, 2019
Incident Report for Kennesaw State University
Resolved
Credit/debit transactions are now processing at all K-Cash Machines. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Jan 09, 2019 - 21:08 EST
Investigating
Credit/debit transactions are currently unable to be processed at the K-Cash Machines.

UITS and the vendor are currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Jan 07, 2019 - 16:41 EST
This incident affected: Business Operations (KCash Manager).