About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

VoIP Service Issues - October 10. 2018
Incident Report for Kennesaw State University
Resolved
Service has been restored for the VoIP phone services.
Posted about 6 hours ago. Oct 15, 2018 - 15:31 EDT
Update
We are continuing to investigate this issue.
Posted 5 days ago. Oct 10, 2018 - 18:29 EDT
Investigating
Some users are currently reporting service issues with KSU VoIP phone services.

KSU Telecom is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 5 days ago. Oct 10, 2018 - 18:28 EDT
This incident affected: Campus Telephone System.