About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Housing Portal (StarRez) Service Issues - April 5, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that the Housing Portal (StarRez) is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted 7 months ago. Apr 08, 2019 - 17:02 EDT
Identified
Housing Portal (StarRez) is currently experiencing issues that may affect your ability to access or use the service.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 7 months ago. Apr 05, 2019 - 11:11 EDT
This incident affected: Housing Portal (StarRez).