The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
University Information Technology Services (UITS) has confirmed that D2L Brightspace is functioning normally at this time.
You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Sep 11, 2020 - 16:59 EDT
Investigating
Some users are currently reporting service issues with the My Courses Widget in D2L Brightspace. Users may still use the "Select a course..." option from the waffle icon as a workaround.
UITS is currently investigating these issues. We will provide further updates as they are available.
You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Sep 11, 2020 - 13:38 EDT
This incident affected: Academic & Research Services (D2L Brightspace).