About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

OwlTrain Service Issues - July 31, 2020
Incident Report for Kennesaw State University
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 11:14 EDT
Investigating
Some users are currently reporting service issues with OwlTrain. Users are experiencing log-in issues as well as slow speeds once inside the system.

Skillport is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Jul 31, 2020 - 09:40 EDT
This incident affected: Academic & Research Services (OwlTrain / Skillport).