About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Owl Express Service Issues - August 3, 2020
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Owl Express is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Aug 03, 2020 - 18:26 EDT
Identified
Some users are currently reporting service issues with Owl Express.

UITS is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Aug 03, 2020 - 17:47 EDT
This incident affected: Student Records (Banner / Owl Express).