About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Card Transaction, Printing, and Scanning Service Issues Nov. 9
Incident Report for Kennesaw State University
Resolved
The issue has been resolved and service for printing, scanning, and transactions for meal plans, dining dollars, and k-cash have been restored. Thank you for your patience.
Posted Nov 09, 2018 - 10:27 EST
Update
UITS technicians are continuing work to restore these services. Thank you for your patience.
Posted Nov 09, 2018 - 09:19 EST
Identified
The Blackboard card transaction system is currently experiencing issues that may affect your ability to access or use the service. This affects printing, scanning, and card transactions for dining dollars, meal plans, and K-cash.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Nov 09, 2018 - 07:23 EST
This incident affected: Productivity Services (Copy Print, Scanning) and Business Operations (KCash Manager).