About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Pilcher & Convocation Network Service Issues - January 18, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Pilcher & Convocation Center Network is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted 4 months ago. Jan 18, 2019 - 13:41 EST
Identified
Some users are currently reporting service issues with network slowness or dropped connections in Pilcher & the Convocation Center.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 4 months ago. Jan 18, 2019 - 11:27 EST
This incident affected: Network (Network - Kennesaw Campus).