About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

Office365 Service Issues - May 2, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Office365 and their related services are functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted 6 months ago. May 02, 2019 - 19:22 EDT
Investigating
Some users are currently reporting service issues with SharePoint, OneDrive, Word, Excel, PowerPoint, etc. within Office365.

Microsoft is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted 6 months ago. May 02, 2019 - 16:38 EDT
This incident affected: Office 365 / Campus Email.