About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Microsoft Teams Automatic Update - 04/01/2024
Incident Report for Kennesaw State University
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 10:52 EDT
Investigating
Microsoft recently announced that all remaining users of classic Teams will be automatically updated to new Teams on Monday, April 1. (Some users may experience changes as early as March 31.) This update brings improvements to enhance your communication and productivity:

• A new channels experience with a new conversation view in channels, an updated compose box, a streamlined information pane, and an enhanced in-channel search experience.
• External presenters can now receive unique links to join Teams meetings directly, bypassing the lobby.

Because Microsoft will automatically update Teams on your devices on April 1, you do not need to take any action. During the update, there may be a brief period of approximately 10 minutes when you will be unable to use Teams.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Mar 25, 2024 - 15:45 EDT
This incident affected: Communications (Microsoft Teams).