About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at service@kennesaw.edu.

HireTouch Service Issues - September 11, 2018
Incident Report for Kennesaw State University
Resolved
Service has been restored for Hiretouch. We thank you for your patience.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted 2 months ago. Sep 12, 2018 - 16:14 EDT
Update
We are continuing to monitor for any further issues.
Posted 2 months ago. Sep 12, 2018 - 16:09 EDT
Monitoring
HireTouch service is currently functional and UITS will continue to monitor this system for stability. If you continue to experience issues with HireTouch, please contact the Service Desk at 470-578-6999 or service@kennesaw.edu.
Posted 2 months ago. Sep 11, 2018 - 12:10 EDT
Identified
HireTouch is currently experiencing issues that may affect your ability to access or use the service.

University Information Technology Services and the vendor are currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at 470-578-6999 or service@kennesaw.edu
Posted 2 months ago. Sep 11, 2018 - 08:53 EDT
This incident affected: HireTouch.