About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Phone and Internet Service Outage in Architecture - N Building - February 20, 2019
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that Phone and Internet Services in Architecture - N Building on the Marietta campus are functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Feb 21, 2019 - 08:34 EST
Identified
Phone and Internet Services in Architecture - N Building are currently experiencing issues that may affect your ability to access or use the services.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Feb 20, 2019 - 22:24 EST
This incident affected: Communications (Network - Marietta).