The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
We are pleased to confirm that the water outage on the Marietta Campus has been resolved. Systems have been tested and are now fully operational. All services should be restored.
Thank you for your patience during this time. If you experience any further issues, please don’t hesitate to reach out to Plant Operations at 470-578-6224 or email plantops@kennesaw.edu. For calls after 5:00 PM, please call KSU Public Safety Dispatch at 470-578-6666.
Posted Jul 24, 2026 - 17:21 EDT
Update
Water service is expected to be restored this evening. Marietta students living in on-campus housing should check their KSU email for additional information.
Posted Jul 24, 2026 - 16:33 EDT
Identified
Current Known Impact & Information:
A waterline was damaged near the Globe during contractor work on new electrical lines. Plant Operations staff are on site evaluating the issue. At this time, the outage is impacting the majority of the Marietta Campus
This outage is affecting all water services including, restrooms, drinking fountains, dining areas, and labs.
A contractor is currently on site to repair the damaged lines, and repairs are expected to be completed sometime this evening.
Plant Operations is actively monitoring progress and will provide updates as additional information becomes available.
For additional questions, please call 470-578-6224 or email plantops@kennesaw.edu. For calls after 5:00 PM, please call KSU Public Safety Dispatch at 470-578-6666.
Posted Jul 24, 2026 - 15:18 EDT
This incident affected: Utilities & Engineering Services Marietta (Campus Water System).