About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

KSUMail Intermittent Email Slowness Service Issues - Wednesday, May 8, 2024
Incident Report for Kennesaw State University
Resolved
Microsoft has resolved the KSUmail issue affecting the sending of email in a timely manner.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted May 20, 2024 - 10:55 EDT
Identified
KSUMail is currently experiencing issues that may affect your ability to send timely emails. Microsoft has issued an update that some emails may take as long as twenty minutes to send.

Microsoft is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted May 08, 2024 - 08:22 EDT
This incident affected: Communications (Office 365 / Campus Email).