The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Update -The source of the gas leak has been identified and successfully repaired. -All campus gas, power, and technology services have been fully restored.
Current Known Impact Construction work is still underway in the area where contractors accessed the conduit for repairs. This is located along the sidewalk path between the Engineering Lab and Design 1 Buildings. Please avoid this area, as it contains broken concrete, heavy machinery, and deep trenches.
Timeline Contractors will continue to work on this project through the end of the week.
Logistics For safety, please advise patrons to use alternate routes and avoid the affected sidewalk.
Posted Dec 02, 2025 - 21:17 EST
Update
All technology services have been restored.
Posted Dec 02, 2025 - 19:40 EST
Update
Current Known Impacts: The outage will fully impact Marietta, including: -Access to on-premises systems and services that depend on campus networking -Wired and wireless network connectivity -The academic and administrative buildings, except the Recreation and Wellness Center, on the Marietta Campus are currently without heat and hot water. -The Academic Building (H) currently has no power and is closed. -Some elevators on the Marietta Campus are temporarily out of service during this time. -The Johnson Library is also closed. -Big Owl Bus service remains available between both campuses. -Students with classes on the Marietta Campus should contact their faculty or login to D2L regarding any changes to their classes during modified operations.
Posted Dec 02, 2025 - 11:56 EST
Identified
The Marietta Campus will move to modified operations today, December 2, 2025 due to ongoing campus infrastructure impacts from yesterday’s Gas Leak situation. Campus is safe, but internet and heat for some buildings on campus are out. Kennesaw Campus will maintain Normal Operations. Stay tuned to your KSU email for additional campus communication and updates. For additional information, please visit the Office of Emergency Management website here- https://campus.kennesaw.edu/offices-services/emergency-management/index.php
Posted Dec 02, 2025 - 09:21 EST
This incident affects: Utilities & Engineering Services Marietta (HVAC(Heating, Ventilation, and Air Conditioning) Systems, Campus Electrical System, Campus Gas System).