About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

D2L "My Courses" Widget Service Issues - {December 4, 2019}
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that D2L is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Dec 05, 2019 - 10:04 EST
Update
We are continuing to investigate this issue.
Posted Dec 04, 2019 - 16:41 EST
Investigating
UITS has received reports of the “My Courses” Widget either loading very slowly or failing to load.

D2L and USG are currently investigating these issues. We will provide further updates as they are available.

Even if the course tiles do not load, courses can still be accessed via the Course selector on the D2L Homepage.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Dec 04, 2019 - 15:04 EST
This incident affected: Academic & Research Services (D2L Brightspace).