The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
All systems have been successfully restored, and we are monitoring their performance to ensure continued stability.
Posted Dec 02, 2025 - 19:20 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 02, 2025 - 14:47 EST
Identified
Due to ongoing campus infrastructure impacts from yesterday’s Gas Leak situation all technology systems on the Marietta campus are shut down affecting network, Teams Calling, VPN, and computer sign-ins. Safety teams are monitoring conditions closely. We will provide updates as additional information becomes available and systems are restored.
Posted Dec 02, 2025 - 07:41 EST
This incident affected: Accounts & Identity Management (Authentication Services), Productivity Services (Global Protect VPN), Communications (Network - Marietta, Teams Calling, WiFi - Marietta), and Student Records (OnBase).