About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

College of Computing and Software Engineering (CCSE) Virtual Desktop Service Issues - Tuesday, April 29, 2025

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that the College of Computing and Software Engineering (CCSE) Virtual Desktops are functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Apr 29, 2025 - 15:34 EDT

Identified

CCSE Virtual Desktops are currently experiencing issues that may affect your access.

UITS is currently investigating these issues and working quickly to fix them.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Apr 29, 2025 - 14:30 EDT
This incident affected: Academic & Research Services (CCSE Student Virtual Desktops).