About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

HVAC Outage in 920 Norton Hall- Marietta Campus

Incident Report for Kennesaw State University

Resolved

We are pleased to confirm that the air conditioning system outage in 920 Norton Hall has been resolved. Systems have been tested and are now fully operational. All HVAC services in the building should be restored.
Posted Apr 04, 2025 - 15:58 EDT

Identified

The building's chiller is currently out of operation. As a result, the air conditioning system will be unavailable until a warranty technician arrives to diagnose the issue. All floors of the building will be impacted by this outage, except for Public Safety's Communications Center. Repairs are projected to be completed by end of day Friday, April 4.
Posted Apr 03, 2025 - 08:13 EDT
This incident affected: Utilities & Engineering Services Marietta (HVAC(Heating, Ventilation, and Air Conditioning) Systems).