The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 10, 2025 - 12:57 EDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 03, 2025 - 07:58 EDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted May 30, 2025 - 09:04 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 26, 2025 - 06:00 EDT
Scheduled
We will be performing scheduled maintenance outside of Kennesaw Hall on Monday, 5/26-Tuesday, 5/27. A contractor will be performing construction work on the concrete and paver surfaces surrounding the 'Tea House' (gazebo) area. We do not anticipate any disruption to the pathway from the Convocation Center to Kennesaw Hall. However, due to ongoing construction activities involving noise, dust, and debris, we recommend that patrons use alternative entrances to Kennesaw Hall, such as the rotunda area near the Registrar's Office or the Northwest entrance near the Bagwell Building.
Posted May 23, 2025 - 07:05 EDT
This scheduled maintenance affects: Utilities & Engineering Services Kennesaw (Campus Roads and Parking Lots).