About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Network Service Issues on 3rd Floor Social Science - Monday, March 30, 2020
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that network for the 3rd floor of Social Science is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Mar 30, 2020 - 16:39 EDT
Investigating
UITS is currently investigating network issues on the 3rd floor of the Social Science building. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Mar 30, 2020 - 14:21 EDT
This incident affected: Communications (Network - Kennesaw).