About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Power Outage - Summit I

Incident Report for Kennesaw State University

Resolved

The power outage affecting Summit I has been resolved as of 2:58am.
Posted Mar 19, 2025 - 03:37 EDT

Identified

Our team is addressing a power outage at Summit I. As of 6:27pm, we have identified the root cause and are working with Georgia Power to restore service. Repair crews are estimated to arrive on site at approximately 8:15pm and repairs may take up to 3 hours.

Impact: Portions of Summit I are currently without power.
Posted Mar 18, 2025 - 20:21 EDT
This incident affected: Utilities & Engineering Services Kennesaw (Campus Electrical System).