The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2024 - 07:00 EST
Scheduled
Banner, Degree Works, SAS, and Ad Astra will be unavailable for system maintenance beginning Sunday December 15 2024, 7:00 a.m. and extending through Monday, December 16, 2024, 12:00 a.m.
Anything that uses data from the Banner Database will be impacted, including EMS and KSU Connect
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Nov 21, 2024 - 18:15 EST
This scheduled maintenance affected: Student Records (Banner Admin Pages, Banner / Owl Express, DegreeWorks) and Business Operations (KSU Connect, SAS Reports).