The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 21, 2026 - 07:00 EDT
Scheduled
Impact Details: Description & Location: Plant Operations will repair a leaking main trunk line, the primary water supply line that delivers water throughout the building.
Schedule: Work will begin on Friday, August 21, at 7:00 a.m. Water service will be off from 7:00 a.m. to 11:00 a.m.
Reason: A leaking trunk line must be isolated and repaired to prevent further deterioration and restore reliable water service. The outage is necessary to safely complete this repair and ensure continued dependable service to the building.
Logistics: This repair will impact all water fixtures in the entire building, including restrooms, drinking fountains, kitchens, and other plumbing-dependent areas.
Please feel free to reach out with any questions or specific constraints we should keep in mind at plantops@kennesaw.edu or call 470-578-6224.
Posted Aug 07, 2026 - 14:06 EDT
This scheduled maintenance affected: Utilities & Engineering Services Kennesaw (Campus Water System).