About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Microsoft OneDrive Issues Identified - Wednesday, 03/26/2025

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that Microsoft OneDrive is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Mar 31, 2025 - 08:38 EDT

Investigating

OneDrive is currently experiencing an issue preventing email notifications to send when a file is shared. A temporary workaround is to copy the link from OneDrive to paste in an email or Teams chat.

We will share updates as they become available.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Mar 26, 2025 - 15:26 EDT