About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Microsoft Office 365 Issue Identified - Thursday, 10/09/25

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that Microsoft 365 is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Oct 13, 2025 - 08:34 EDT

Investigating

Microsoft has indicated that they are currently experiencing an issue that may impact customers' access to Microsoft 365 services.

We will share updates from Microsoft as they become available.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Oct 09, 2025 - 14:58 EDT
This incident affected: Communications (Microsoft 365 / Campus Email, Microsoft Teams).