The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
The parts needed to complete the repairs have been ordered and are in transit.
Posted Dec 01, 2025 - 14:15 EST
Update
The contractor has engaged the manufacturer to obtain further clarification regarding the issue; however, no definitive answers are available at this time. The system continues to operate at approximately half capacity, so while performance is limited, it remains functional. Given the current mild weather forecast, we do not anticipate significant discomfort within the building.
We will share any new information as soon as it becomes available. If you have any questions, please contact, Kyle Medlen, Maintenance Campus Manager at 470-698-7385 or send an email to plantops@kennesaw.edu.
Posted Nov 25, 2025 - 09:50 EST
Identified
-The heating component within the HVAC system for the Music Building is currently not operational. This does not affect MU109 Recital Hall, as it is served by a separate HVAC unit. If your area contains sensitive equipment, it is advisable to store it in the Recital Hall or an alternative location. -The contractor has identified a significant system malfunction and is actively working to complete the necessary repairs. -Technicians will place additional heaters in designated areas throughout the building to maintain a comfortable temperature.
Posted Nov 11, 2025 - 16:31 EST
This incident affects: Utilities & Engineering Services Kennesaw (HVAC(Heating, Ventilation, and Air Conditioning) Systems).