About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

KSU Facilities Portal Service Issues - Tuesday, 01/06/26

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that the KSU Facilities Portal is functioning normally at this time.

If you have bookmarked the KSU Facilities Portal, please update your bookmark to https://ksu.tririga.com/p/web/workplaceServices
Posted Jan 09, 2026 - 16:34 EST

Identified

The KSU Facilities Portal is currently experiencing issues that may affect your ability to access the website via the Facilities website or a bookmarked link. You may access the portal by using the link https://ksu.tririga.com/p/web/workplaceServices

UITS is currently investigating these issues and working quickly to fix them.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Jan 06, 2026 - 10:13 EST
This incident affected: Business Operations (KSU Facilities Portal).