About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Microsoft Office 365 Issue Identified

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 15:02 EDT

Update

Access to SharePoint Online, OneDrive, Outlook on the web and Outlook desktop has been restored.

Some users may be unable to sign in to OneNote using iOS devices.
Posted Aug 21, 2026 - 08:40 EDT

Investigating

Microsoft has indicated an issue with Office 365 impacting the following actions:

- Some users may be unable to search for content in SharePoint Online, OneDrive, Outlook on the web, or Outlook desktop

We will share updates from Microsoft as they become available.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Aug 18, 2026 - 08:05 EDT
This incident affected: Communications (Microsoft 365).